PMK Control Plane is experience degradation

Incident Report for Platform9

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 05:14 PDT

Identified

An issue has been identified affecting all the PMK Control Planes, and some PMK customers are experiencing service degradation.
Our team has identified the issue and is working to implement the fix.
Posted Apr 22, 2026 - 22:56 PDT
This incident affected: Platform9 Cloud.